Spectre and Meltdown vulnerabilities

NetComm Wireless is aware of the recently discovered security vulnerabilities, Spectre and Meltdown.

  • Meltdown vulnerability affects Intel processors and a few ARM based processors which are not used in any of NetComm Wireless devices.
  • Spectre affects multiple ARM processors, from Cortex-A8 upwards, used in some NetComm Wireless devices.  However, the existing security design of the Operating System prevents our devices from being vulnerable to attack because remote script / code injection activity is blocked.

At this point, NetComm Wireless does not consider Spectre and Meltdown vulnerabilities as a threat to NetComm’s Fixed Broadband and M2M / IoT gateways and routers and does not see any need to release any patches for these vulnerabilities.

We are taking this security matter seriously, and should you have any further questions, please contact Support by opening a ticket.